EnderDevelopment - Jar Compilation Failure – Incident details

Jar Compilation Failure

Resolved
Partial outage
Started 5 days agoLasted about 6 hours

Affected

EnderDevelopment - AI Platform

Partial outage from 10:05 AM to 4:20 PM

Dashboard

Partial outage from 10:05 AM to 4:20 PM

EndAI - Main Backend

Partial outage from 10:05 AM to 4:20 PM

Updates
  • Resolved
    UTC
    Resolved
    This incident has been resolved.
  • Update
    UTC
    Update

    The issue has been largely mitigated, and most JAR compilation requests are now completing successfully.

    However, we are continuing to monitor reports that some particularly complex prompts may still cause JAR compilation failures. This behavior was not previously observed and appears to be related to the upstream issue.

    Our team is actively monitoring the situation and applying additional fixes to restore full stability. We appreciate your patience while we complete the final improvements.

  • Identified
    UTC
    Identified

    We have identified the root cause of the issue affecting our Spigot content, repositories, and Maven infrastructure. The problem originates from our upstream provider, which is causing some JAR compilation requests to fail.

    Our team is actively working with the upstream provider to resolve the issue as quickly as possible. We will continue to provide updates as progress is made.

    Thank you for your patience and understanding.

  • Investigating
    UTC
    Investigating

    We are currently investigating an issue affecting our Spigot content, repositories, and Maven infrastructure due to an upstream provider problem. As a result, some JAR compilation requests may fail or be unable to complete successfully.

    Our team is actively investigating the root cause and working on a resolution. We will provide further updates as more information becomes available.

    We apologize for any inconvenience and appreciate your patience.