EnderDevelopment - Intermittent Instability via Cloudflare Proxy – Incident details

Intermittent Instability via Cloudflare Proxy

Resolved
Partial outage
Started about 2 months agoLasted about 1 hour
Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Investigating
    Investigating

    We are currently investigating an intermittent instability affecting dash.enderdevelopment.com when accessed through Cloudflare.

    Some users may experience:

    • Error 520 (Unknown Error)

    • Temporary connection drops

    • Inconsistent behavior on specific routes

    Initial analysis indicates the issue appears to be related to the interaction between Cloudflare’s proxy layer and the origin server connection handling. Direct origin access does not show persistent failures.

    We are actively monitoring the situation and applying configuration adjustments to improve connection stability.

    Further updates will follow as soon as additional diagnostics are completed.